Archlinux und co.: System hängt immer wieder beim Kopieren von Dateien auf ein USB Gerät…

Heute bin ich -mal wieder- auf ein richtig nerviges Problem in Archlinux gestoßen: Mein System hängt regelmäßig beim Kopieren von Dateien auf einen USB Stick. Es hängt sich nicht komplett auf, sondern immer “intervallmäßig” immer wieder für 15-30 Sekunden. Dabei hängt der komplette X Server, nur der Mauszeiger bewegt sich. Ebenso sind die Konsolen 1-6 (strg+alt+F1…F6) nicht betroffen. Ich nutze übrigens den aktuellsten Kernel 3.2.4.

Nun ist ja hinlänglich bekannt, dass der Linuxkernel seit längerem “leichte” Probleme hat mit USB Transfers und dem USB Subsystem in der Hinsicht, aber dass es so krass ist hätte ich nicht gedacht, wir reden hier nicht von einem schnellen USB-Stick oder sowas, sondern von vllt. 3 MB/s Transferrate.

Weiterhin gab es berichte, dass sowas auch beim Kopieren auf NTFS Laufwerke und unter einigen anderen Umständen auftritt.

Es gibt wohl 2 Lösungswege:

1) Deaktivieren von USB Legacy im Bios soll helfen. Hat aber den Nachteil, dass man keine USB Tastatur mehr nutzen kann in Grub (beispielsweise).

2) Die bessere Lösung ist folgender Eintrag in /etc/rc.local:

echo madvise > /sys/kernel/mm/transparent_hugepage/defrag

Das hat ansonsten eigentlich keine Auswirkungen auf das System, manche Leuten berichten sogar von höheren Transferraten ;)

Das Problem liegt also irgendwo in den “transparent hugepages” verborgen, jedenfalls ist das auch der Grund warum Ubuntu und co. nicht betroffen sind, die setzen nämlich standardmäßig “madvise” dafür. Gefunden habe ich diese Lösung im englischen Archlinuxforum, Danke an finidine.

Anscheinend soll das Problem übrigens mit Kernel 3.3 behoben sein, ein LWN.net Artikel erläutert das etwas.

Ich bin jedenfalls froh vorerst eine Lösung zu kennen…:)

Comments (2)

  1. 22:42, February 6, 2012Toadie  / Reply

    Interessante Sache. Kann bisher nicht klagen aber falls das Problem auftreten sollte, weiß ich jetzt bescheid.
    Danke!

  2. 02:00, February 8, 2012Archer  / Reply

    Hey, hab grad diese Seite über google gefunden, weil ich genau das Problem hatte. Die Lösung funktioniert einwandfrei und ich dachte schon irgendwas ist im Argen mit meinem Rechner. Danke!

Leave a Reply

Allowed Tags - You may use these HTML tags and attributes in your comment.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Pingbacks (0)

› No pingbacks yet.